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[image: ]MANIPULATING IMAGES ON THE MAP CANVAS

Viewing Panels (like the layer control) and Toolbars

Right-click on open grey area at upper part of the screen, then select the panel or toolbar to display or close

Or/ View > Panels  or  View > Toolbars


Map Viewing Tools
[image: ] moves map about
[image: ] Zoom in & out, or change scale below  [image: ]
Selecting an area with the [image: ] tool expands that area to fill screen
[image: ] Zoom to selection and to layer
[image: ] Zooms to view the full, uppermost layer in Layers Panel
[image: ][image: ] Allows you to toggle through previous or subsequent zooms
[image: ] Click then select an area point, to view the fields and corresponding values in its Attribute Table

[image: ]
Viewing Attribute Table
[image: ] Brings up the attribute table for the layer selected in the Layers Panel (right)

[image: ]Measuring 
Click on measuring icon to measure distance, angle or area.

To measure a line, select ‘measure line’, left-click with mouse on map where you want to commence the measurement, drag mouse, then right-click to end selection of the line.

To measure an area, left-click on map to mark the start point, drag mouse around while holding down left button, left-clicking at each point, then right-click to conclude.

Co-ordinates, Scale and Magnification 
These are shown at the bottom of the screen.
[image: ]

Co-ordinates represent the position of the mouse pointer over the map. The co-ordinates can be copied.
Type in co-ordinates, scale or rotation, and the map will change to reflect those values
Co-ordinates illustrated here are in degrees. 
The sequence of co-ordinates is:  X/longitude/easting  ,  Y/latitude/northing

[image: ]Co-ordinates can be toggled with Extents, which are the latitude, longitude of the lower-left and upper-right of the screen, respectively


SELECTION – through the map or its attribute table – the result is the same
First, in Layer Frame, activate the layer that you want to select features from
1. Clicking
Selection Tools
[image: ][image: ] Allows you to choose to select:
·  individual features (hold down Control to select more than one area or to unselect a single area), 
· by polygon (Right-click to close the polygon), 
· by freehand (allows you to carefully select an area within an area), 
· and by radius (R-click on map then R-click again to mark centre and start selection

[image: ] Allows you to select all features of a layer, invert selection or use expression

[image: ]Selection within Attribute Table
[image: ]Activate layer in the Layer Panel, click on Attribute Table button ,          then manually select records or use selection buttons to select by expression (see above), invert selection etc. The map will show the selected areas.






Selecting or Filtering Data in Form View
Toggle Attribute Table to Form View (at lower right)  [image: ]
Click filter [image: ] icon
Type criteria into relevant fields, as the basis for seleting or filtering records
(For more, see section ‘Attribute Tables’)

2. Expressions  for selecting / labelling: select subset of a field without changing it. 
Calculations, used to create new fields in the Attribute Table, actually do something to the field
Select by Expression – can be performed from map view or Attribute Table
This allows an expression to be formed using:
Operators: expressions, such as =, >, <, Like, %, And, Or, Not, In, Toreal, Toint, Tostring
Fields and Values: Fields from the layer activated in the Layers Panel
[image: ]Values of specific features within a particular field in that layer: to obtain the values within a field, open ‘Fields and values’ > select field > click on ‘All unique’ button at lower right. This shows the unique values in that field, and allows you to select one of them for inclusion in your expression

If you cannot find the window for viewing the values in a field, click on the far edge of the window, hold mouse button down and pull to the left to reveal the window
[image: ]

For example, to select the feature ‘Alpine’, from the Local Governments layer, the expression at right specifies that in the field ‘GeoS_CODE’ (which contains LGA names) the value must be ‘Alpine’





‘=’ specifies a precise value,  ‘LIKE’ coupled with ‘%’ is less specific,  ‘IN’ selects multiple values:
"Municipality" = 'Maribrynong' 	 selects Maribyrnong
“Municipality” != ‘Moreland’  	 selects everything except Moreland
"Municipality" like '%ong' 	 selects G. Dandenong, Geelong, Maribyrnong
"Municipality" like '%and%' 	 selects Moreland and G Dandenong
“Municipality” IN ('Alpine', 'Cardinia', 'Casey')  - does not work with % operator though
Field names are case sensitive, so type names or fragments of names into expressions carefully
‘OR’ ‘AND’ adds statements together
"Municipality" = 'Alpine' OR  "Municipality"  LIKE  '%ong' 	 ‘Alpine, Geelong, Maribyrnong…etc
"Municipality"  =  'Alpine'  AND “School_Name”   LIKE  '%Secondary'
‘NOT’ reverses the effect of ‘LIKE’, ‘IN’  – but not ‘=’
"Municipality"   NOT  LIKE  '%ong'	 all municipalities except Geelong, Dandenong etc
"Municipality"   NOT  IN ('Alpine', 'Cardinia') 	 all municipalities except Alpine and Cardinia
[image: ]
Click ‘Select’ at lower right-hand margin of window and choose from options – including adding to or selecting within an existing selection. 


[image: ]Filter – similar to selecting by expression, except that you have retained all records in your layer, but only filtered them to show a selection.
Right-click layer in Layer Panel > Filter
[image: ]


In window which appears, double click on the field required for the expression, then add operators using rules outlined above.

If you select ‘All’ beneath the upper-right window, it will show all the values in the field, for you to select from. Double-click on one to add to expression

Click ‘Test’ to see if your expression works
OK.

As with selections, you can ‘Save As’ and create a new layer based on the features you have filtered for.
[image: ]The filtered features will show up in the Attribute Table as well – but they cannot be edited.
Once finished: Select layer in Layers Panel > Filter > Filter window appears > 
3. Boundaries
Boundary Select
Selecting items (within ‘lower’ layer) encompassed by, or overlapping, the selected boundary of another layer (the ‘upper’ layer).

Eg: Suburbs within Greater Dandenong – selected from a Local Government layer
Activate the upper layer (Local Government, in this case) – which you want to use to select items from ‘lower’ layer (suburbs in this instance) that fall within one of its polygons
[image: ]Select a single local government – eg: ‘Greater Dandenong’ –the boundary we will select within


Vector > Research tools > Select by location


[image: ]

In dialogue box , under ‘Select features in’ choose the ‘lower’ layer – the suburbs layer – as it is suburbs that you want to select 

Under ‘That intersect features in’, select the ‘upper’ layer – that the suburbs would fall within –  in this case, local government layer

Check boxes below to describe the overlap you want e.g.: touching, within feature etc.
You can also use this selection as a new selection or add/remove from an existing selection
Check ‘Only selected features’ to ensure that selection only occurs within the selected part of the ‘upper’layer

OK then Close

Selections show up in Attribute Table
Incidentally, you can click on ‘Open Attribute Table’ to view the attributes 
- the selected features (rows) will be shaded

[image: ]






Save Selection as a New Layer
To save the selected suburbs as a layer: Activate suburbs layer in Layers Panel > right click > Save as > in dialogue box check ‘save only selected features’ and give the new layer a name and location.

Unselect
[image: ] Unselects all selected objects on the map


[image: ]CLIPPING A LAYER (to limit its extent to that of another layer)
Similar to boundary select > save selection
Eg: to clip a Suburbs layer to include only those which fall within Brimbank
[image: ]
Install both layers in the Layers Frame

Select part of the clip layer (Local Governments, here) to form the boundary of the clip

                              Vector > Geoprocessing Tools > Clip




[image: ][image: ]Select:
‘Input vector layer’ – the one being clipped
‘Clip layer’ – the one to whose extent the input layer is clipped
Check ‘Use only selected features’ from the clip layer
Select location & name of the resulting layer

[image: ]The result is a selection of suburbs from the Suburbs Layer, that matches the extent of a single municipality in a layer ‘Local Governments’
If you clip a layer – such as SA1 areas – you can then map characteristics of that part of the layer which has been clipped, such as SA1 ares within a municipality

Clipping to remove that part of an area which is encompassed by another layer
Eg: to clip a Suburbs layer to remove suburbs which fall within Brimbank
[image: ]
Vector > Geoprocessing Tools > Difference

[image: ]





Select ‘Input layer’ – to be clipped, and ‘Difference layer’ whose extent will determine which features of the input layer are to be removed
[image: ]



The resulting ‘difference’ layer, shows a gap where suburbs that fell within the area of a single municipality, have been removed 


So you can select features of a map to create another by:
· Selecting > Save as
· Filtering on the Map Canvas >Save as
· Clipping
· Select > Control_C > Paste into an editable Shapefile layer of compatible type (points/polygons) – this does not retain the attributes of the file being copied though


LAYER CONTROL
[image: ]
Layers Panel
Situated at lower left of screen
To close, click cross at upper right-hand side of the Panel

If you add a layer (Layer > Add Layer > Add Vector Layer) it will appear in the Layers Panel
· Select and drag a layer to raise or lower it.
· Click on box next to layer to hide or show a layer on the map
· Double-click on the layer name to bring up the Layer Properties window to change its appearance 


[image: ]Create a Layer




Scratch Layer – for drawing only, and with no Attributes, but can be saved
[image: ](whereas a new Shapefile layer has to be saved)

New Shapefile layers – include dots, lines and polygons (see later section)

[image: ]Add Layer
Layer > Add layer > Vector Layer

[image: ]


Then select the layer required from your files.
[image: ]





OR/
Double-click on a file in the Browser Panel



To open an old Mapinfo table, select the version called ‘MapInfo Table’ with suffix ‘.tab’
[image: ]

To open a file created by CGIS, select the one with the suffix ‘.shp’ 




Aerial Layer
Located at T:/GIS/Photo/Photo Dec 2017/Mosaic/greater-dandenong_2017dec11-air_vis_10cm_mga55.ecw
[image: ]To open: Layers > Add Vector Layer > Add Rasta Layer

Duplicate Layer
Select layer in Layer Panel > Layer > Duplicate layer

Remove Layer
Layer > Remove Layer
Save a Layer
Select layer in Layers Panel
Layer > Save as > then give a name (no spaces) and select a location for the new file
[image: ][image: ]









You may also decide whether or not to add the saved file to the map 
[image: ]

Creating and Saving a Subset of a Layer
Activate the layer in Layers Panel, then select a part of the layer
[image: ]
Layer > Save As.

Tick ‘Save only selected features’

Type name and select location for the new layer file

You may also tick ‘Add saved file to map’ to add the new layer to 
your map layers in the Layers Panel.

[image: ]

Merging Layers
Vector > Data Management Tools > Merge Shapefiles to One
The layers must have same geometry type: point, line or polygon

[image: ]


Check ‘Select by layers in the folder’ (Layer panel)
Select layers to merge (input files) as well as a
 name and location for the new, merged, file
[image: ]





[image: ]



The resulting file now contains fields and values from the two separate files, as the Attribute Table at right illustrates
In this instance, the field ‘id’ from a group of dots is combined with attributes from a file of local schools.




[image: ]CREATING A LAYER OF POINTS

Layer > Create Layer > New Shapefile Layer

In window, select ‘Point’ 


In ‘Fields List’, a single attribute (or field) called ‘id” appears
You may add or remove fields, giving each a name, length and type (below)
[image: ]

You may remove any field too, including the default ‘id’field created by the computer



OK > select name and file location for this new layer - which we will call the ‘dot layer’
The ‘dot layer’ will appear in the Layers Frame
Open another layer to serve as a point of reference for placing the dots in the ‘dot layer’
Activate the ‘dot layer’ > click ‘Edit’ button [image: ] > Click ‘Add feature’  [image: ]

Click mouse in location where you wish to place a dot 

[image: ]
In window which appears, type information into the fields you added when you created the ‘dot layer’ 




When you’re finished, change appearance in Layer Properties window, if necessary.

When done, Layer > Save as, or untick edit button [image: ], and you will be prompted to save


Adding further Dots Later
At any time, you can open the layer, then:
· Click ‘Edit’ [image: ], click add new features [image: ] along with the attributes of each.
· Open the Attribute Table for this layer, make it editable and add or amend its attributes


Editing Attributes of each Dot
Activate dot layer in Layers Panel > Open Attribute Table >make editable > amend data in shaded row (representing a selected dot) or in other rows


CREATING A LAYER OF POLYGONS, CIRCLES OR LINES
Eg: for highlighting a study area or area within a certain radius

Creating Layer
Layer > Create layer > New Shapefile layer [image: ]
[image: ]
Select ‘Polygon’ or ‘Line’ 


Give this new ‘polygon layer’ a name and location

In window, add new attributes, or remove default ‘id’, if required – as per previous page > OK











Drawing Your Shapes
Click edit button [image: ] to start adding circles, lines, polygons

Polygon or Line: Click Add Feature button [image: ]and draw a polygon onto the map layer, then right-click to finish
Move the drawing: Click ‘Move feature’ button [image: ], select feature and move it
[image: ]
Adjust drawing: Select ‘Check Node Tool’, [image: ] > select node (it’ll turn blue) :
· Then hold left mouse down and drag the node to a new position or/
· Click ‘Delete’ to remove

[image: ]Add new node: double-click on perimeter of the polygon or line to create a new node


Changing Appearance of Dots, Lines or Polygons
Activate and double-click layer in Layers Frame > change colour, outline etc. in Layer Properties window 


Deleting Dots, Lines or Polygons
Make layer editable [image: ] > Select object > Delete


Copying and Pasting Dots, Lines or Polygons into a New Layer
Select some dots/polygons from current active layer > Control_C
Now, to paste the items:	In existing layer: make editable [image: ] > Control_V
	Into new layer: Edit > Paste features as > New vector layer


CREATING BUFFER LAYERS FOR POINTS OR POLYGONS
Activate layer to be buffered
Select polygon/s or dot/s to be buffered – unless you want the buffer may be added to all of them

[image: ]



Vector > Geoprocessing Tools > Buffer






[image: ]

Select layer for buffer
Note ‘Use only selected features’ is ticked

Add buffer distance (which is in meters) 




Click ‘Browse’ to give a name and location to this new layer



With this buffer superimposed, objects in a layer within the buffer area could later be selected, and characterised as features (towns, houses etc) that lie within x meters (whatever the buffer radius was) of the area that was buffered.



Drawing a Circular Buffer – as a substitute for a circle of exact radius around a point of interest

Layer > Create Layer > New shapefile layer > check ‘Points’ as type > Save
Place a point on this new layer, with a map visible beneath, to guide its placement
[image: ]Activate the new layer in the Layers Frame, select the point, then create a buffer around the point, giving the buffer distance as the radius of the area you wish to highlight.

Once the new buffer layer is done and saved, change its appearance to remove fill from the buffered area

Open the buffer layer above the map layer where you wanted to highlight an area around the point of interest.


LAYER PROPERTIES

Double-click on layer in the Layers Panel  or/  select layer > R-click > Properties
A dialogue window appears, allowing you to:

[image: ]
[image: ]

Set fill, border and point style                                                       Change 
                                                                                                    transparency
                                                                                                                                     of fill



Area includes fill, fill style (solid, brush – nothing, patterns), border style, width and colour
[image: ]
[image: ]For transparent layer:  Colours > transparent fill   or/   Fill Style > no brush 


For adjustment of colour of fill or outline

Slider ‘V’ – brightness/darkness
Vertical bar – colour saturation
Horizontal bar – colour selection











Points – include colour, outline colour, style, width, shape (scroll down to view selection of shapes)
[image: ]













Adjust transparency of whole layer
[image: ]Set label style – including:

Text tab:
Whether to show labels for the layer, 

Label with: What field to use for the labels


Text Style: font, style, size, colour, transparency



Buffer tab:
Addition of a buffer area highlights text against dark backgrounds . Size 0.5 is satisfactory.
[image: ]
Placement tab:
[image: ]For polygons: Placement tab > ‘Around centroid’/‘Offset from centroid‘
Force point inside polygon - to set labels neatly near the centre of polygons.

For points: Choose from ‘Offset from point’ & ‘Around point’
[image: ]

Labelling Selected Features by Expression
 Select features of layer > Save as > check ‘Save only selected features’ > Add labels to this new layer
[image: ]Place this new, labelled layer, above the layer from which it was derived OR/
 Activate map layer > Open Attribute Table > make editable [image: ] > create new field [image: ]
	Name new field as ‘Label’ and set as ‘Whole number (integer)’
	Assign the value ‘1’ to features that you wish to label

[image: ]In Layer Properties window, ‘Label’ tab:
· Select ‘Rule-based labelling’
· Click on the [image: ] symbol at lower window
· [image: ]In window which appears, click  [image: ] button, next to ‘Filter’

· In expression builder window, create expression “Label” = 1 
[image: ]

Select field labelling and other characteristics of the labels, as above > OK

Return to Layer Properties window > Apply > OK


 Select ‘Rule-based labelling’ > Create expression such as: “Municipality” In (‘Ararat’, ‘Buloke’, ‘Casey’ etc)
Choose field for labels & label characteristics
[image: ]
Saving and Applying Styles

Save a Style
Style > Save Style > QGIS Layer Style File > set its name & location

Apply a Style
Style > Load Style > Locate style file of type ‘QGIS Layer Settings’ in folder where it was stored > Double-click on the file – you will be returned to ‘Properties window’ > Apply > OK
But, loaded style must be of the same geometry type (dots/polygons) as the shapefile you are formatting.
[image: ]ATTRIBUTE TABLES (browsers)

Opening an Attribute Table
Or/  Click on [image: ] at top of screen

Selecting Rows (or features) from the Table
Click on far left of the table, to select a row
Hold own Control to select unconnected rows
Hold down Shift to select a continuous group of rows

Selecting Using Buttons
[image: ][image: ][image: ] - Select all fields            Invert selection             Moves selected rows to the top of the table
[image: ]            
[image: ]         - Deselect all             Selection of rows by creating an expression

When you select a row in the Attribute Table, the corresponding feature on the map is selected. Inversely, if you select item/s in a map, the corresponding row of the Attribute Table is highlighted.

Just as you can select features of a map, then save them as another map layer, you can select rows of a map layer in its Attribute Table, then save them as another map layer.

Editing Data in Form View
[image: ]In Attribute Table > make editable [image: ] > toggle buttons in lower right corner [image: ] > then toggle filter button [image: ] to reach Form View edit (vs. Form View filter)
Select a feature at left, then complete or edit its fields in the form at right.


Filtering/Selecting Data in Form View
Toggle Attribute Table to Form View (at lower right)  [image: ]
[image: ]Toggle filter [image: ] icon to reach Form View filter/select (vs. Form View edit, above)
Type criteria into relevant fields, as the basis for filtering/selecting records

Each row adds a criterion to the selection, like ‘AND’ in an expression.

At right of each field, choose whether to filter for values in that field which are equal, not equal, contain or do not contain that value. For real & integer variables, =, >, <, ‘between’ are offered as options.
[image: ]
At lower right of window, choose to select or filter for these attributes
[image: ]

Or/ To filter for selected features, chose [image: ] at lower left of window.



To view selected features on map, goto Map Canvas > click [image: ] button to centre map on the selection 
Creating a Dot Layer to Depict a Selection of Addresses
[image: ]Three steps: 	Select a single address with Attribute Table Form View filter or Select by expression
	‘Zoom to selected features’       , in Map Canvas
	Attach dot to the selected location  

 Activate PropertyNo Layer > open Attribute Table > make table editable

Put Attribute Table in Form View filter – as described above

Type in street name and number in relevant fields [try to be precise, even with streets, so that you can select the option ‘equals’, rather than ‘Contains’ – which often selects a number of features (rows), making it hard for the computer to zoom in on a specific feature]

[image: ]
[image: ]
Click                             at lower right edge of window 

[image: ]Minimise Attribute Table
Return to Map Canvas > click ‘Zoom to selected features’ button [image: ] to view selected feature 
Make sure property layer is active






Activate dot layer > place dot on selected property > type attributes into fields 
When finished, click ‘Unselect all’ [image: ] button and re-activate property layer, to repeat the process.

 In Map Canvas, Activate PropertyNo Layer > click ‘Select by expression’ button [image: ] 
[image: ]

Type in an expression which selects the street name and street number. Street names etc. are case-sensitive in Expression builder

Sometimes an expression such as:
"Street" like 'Wattle%' and  "house_nos" like '2%' and  "Unit_no" like '7%'
Works better than an expression which is more specific, such as:
"Street" like 'Wattle%' and  "house_nos" = 2 and  "Unit_no" =7

Then click [image: ] ‘button at lower right of Expression Builder window (Don’t close Expression Buider)
[image: ]
Click ‘Zoom to selected features’ [image: ] button 


Activate your editable dot layer and place dot on the highlighted yellow property. 
[image: ]
When finished, click ‘Unselect all’      ,, activate property layer and return to Expression Builder, to repeat the process.
[image: ][image: ]Filtering Data in an Attribute Table 
[Doesn’t affect map. It’s only about viewing data in the table]
At lower left-hand edge of the Attribute Table is a filter icon 


Clicking on the filter icon allows you to choose whether to view all rows or ‘features’ in a layer, just selected or visible rows, or use an expression to select rows.
The filtered rows can be copied and pasted into Excel
Closing the Attribute Table restores the full list.


Sorting data in an Attribute Table
Open the Attribute Table 
Click on the field you need to sort by [image: ] and the data rows will be sorted in ascending or descending order of that variable


Editing an Attribute Table – beware: changes you make here are permanent
Select a layer in Layers Panel > open Attribute Table 
Click on the pencil icon at left [image: ] to make the table editable – as with making maps editable
Alter the data: double-click on a cell to edit its contents
Add a field: Click on the 'Add new field' icon at far right [image: ] to add a new field. Name it, select its data type & add data – one row at a time
Calculate a new field: Unlike expressions, these actually do something to a field
Click on the ‘Calculate field’ button [image: ] then….
[image: ]* Name the field and create an expression based on values of the fields and operators
Eg: to_real(“Field”), “Field” * 100 etc
* Select ‘Output field type: whole number, decimal number, text etc.)
[image: ]





* Select ‘Output field length’ and ‘Precision’ – number of digits after the decimal point
[image: ]

[image: ]For more complicated expressions: 
CASE 
  WHEN "cat" > 100 THEN 2
  WHEN "cat" > 10 THEN 1
  ELSE 0
END

                                                                            Delete a field: click [image: ] then select field
                                         Or replace numbers with words, eg: ‘High’, ‘Low’
                                         Fields have quotation marks “, & categories a single ‘
[image: ]Add a row of data (a feature): click ‘add feature’ icon  [image: ] & fill in values for each field of the new row
(illustration, left)




Delete a row of data: select row at left, then click on ‘delete feature’ icon [image: ]





When finished, click on pencil [image: ] to conclude editing, then indicate whether to save or discard changes.
[image: ]




Pasting Data from an Attribute Table into Excel
Activate a layer in the Layers Panel >  open Attribute Table > select rows > Control_C > paste into Excel
Or/ Select part of a layer in Map Canvas or Att Table > filter for selected features > copy > paste into Excel
Pasting Selected SA1 Areas into Excel – for a profile
Select SA1 areas on the Map Canvas > in Attribute Table, filter for selected features (rows) > copy > paste into Excel and select values in the 7-digit SA1 column


JOINING EXCEL DATA TO A MAP LAYER – to make it mappable

Save the Excel data file as a CSV file (Excel file should have field names <10 characters)

Assign Properties to Fields your CSV File – to ensure it can be mapped
Open notepad, and specify the field types in the CSV file, in one line, each in quotation marks and separated by commas     e.g.: For a CSVT notepad file to accompany a CSV file with fields: 7-digit code, Population, Per cent Vietnamese -“String”, "Integer", "Real”
You can specify width & precision of each column  e.g.: "Integer(6)","Real(5.5)","String(22)"

Save this with same name as the CSV file, and in the same folder, but with the suffix  .CSVT
[image: ][image: ]ie: Change file name suffix from .txt                                              to .csvt


When you merge the CSV file with a map file, in QGIS, the field characteristics of the data from the CSV file will be as you specified in this CSVT file, enabling fields with numbers to be treated as numbers. 
To retain these instructions about file type, CSV file must be imported into QGIS via: Layers > Add layer >Add Delimited Text file layer

Import the CSV File into QGIS (the CSVT file, with its instructions, will come too)
[image: ]Layers >Add layer > Add delimited text layer 
[image: ]




In the window which opens, browse to select the CSV data file
Change layer name if you wish

For ‘File format’, check ‘CSV’ (default)

For Geometry Definition, select ‘No geometry (attribute only file)’


[image: ]The file will now appear in the Layers Panel, with an icon

Double-click on the map layer you wish to connect the data table to.
[image: ]
In the Layer Properties window, select ‘Joins’ 

If a layer appears at the top of the window, select it and click [image: ] to remove it (You can’t join fields from a CSV layer which already has fields joined to the map layer)

[image: ]Click on the  [image: ]  button at the lower left-hand side of the window
In the window, select the:
· Join layer (the data table you have saved as CSV and opened as a ‘No geometry’ file)
· Join field (the field in the join (CSV) layer that you want to link to the map layer)
· Target field (the field in the selected map layer to be matched to the join field in the CSV file)
Target & join fields should be the same case – eg for suburbs
· Choose which fields from the join layer (CSV) will be joined to the target field (a map layer) - optional
· Choose a customised field name prefix (this will be appended to the original CSV field names in your map file – 
Keep it short or blank, otherwise the full name of file will be used)
Converting Values in the Combined Map and CSV Layer to Numbers – for mapping attributes (If the step above has not been taken)
When a CSV file is connected to a map layer, its values in some fields may not be recognised as numbers and may therefore be impossible to map as ‘Graduated’ data – that is, as ranges of values, each assigned a different colour

Activate layer in Layers Panel > Open Attribute Table > click [image: ] to make editable

[image: ]Click ‘Calculate attribute field’ [image: ] button




Type new field name 






Select field type  - ‘Whole number’ or ‘Decimal number 
For decimals, under ‘Precision’ sets the required number of values after the decimal point


[image: ]
Under ‘Conversions’ select the operation ‘to_real’ or ‘to_int’








[image: ]


Under ‘Fields and Values’ select the field to be converted to numbers > OK
[image: ]

…and now the new field will appear in the Attribute Table.

[image: ]




This new field may now be mapped as a ‘Graduated’ field’.







Joined Fields are Temporary, Unless the Map Layer is Saved under another Name
To preserve the map layer with joined fields added to it: Layer > Save as
Otherwise, layers added through joining fields are temporary and will disappear when you either:
· Close the CSV layer which provided the fields
· Remove the join, shown here [image: ] in the Join Field window, by selecting it and clicking the delete [image: ] button

IMPORTING TABLE OF DATA WITH LAT & LONG CO-ORDINATES

Open QGIS
Click on comma symbol [image: ] (create layer from comma-delimited text file)
Or/ 
[image: ]

Browse to locate required CSV file

In dialogue box which opens:

· File format: click ‘CSV
· For x field: choose ‘Long’
· For y field: choose ‘Lat’
[image: ]

OK


MAPPING ATTRIBUTE FIELDS 

Mapping Points – that is, giving them colours, based upon their values
Double-click on the layer > click on ‘Style’ tab in the ‘Layer Properties’ window
Then select: 
*‘Categorized’ (If you want dots coloured differently for each nominal category)
*‘Graduated’ (If you want dots coloured by numerical ranges)
Click ‘Column’ to select the field which forms the basis for colouring the dots
In ‘Colour Ramp’ select a colour scheme, if you wish

[image: ]

If ‘Categorised’: just click the ‘Classify’ button at the lower part of the window
[image: ]
If ‘Graduated’: first select whether ‘Quintile’, ‘Equal interval’,’ Natural break’



[image: ]


The dot colours and values within your chosen field that each represents, will appear in the window


 To hide particular categories in the map, uncheck the box at left [image: ] or delete: click [image: ] or[image: ]


[image: ]
 To change appearance of a single dot, double click on it in the Layer Properties panel and make adjustments in the window (right)

 To change appearance of all dots, click  [image: ] to adjust their shape/size/outline
[image: ]
Set layer transparency level, at lower part of screen

Once complete, click ‘Apply’ and ‘OK’
Save the map, if required

[image: ]To revert to a single symbol for dots on the layer: Double-click layer in Layers Panel > select ‘Single symbol’


Mapping Shapes - as for instance, SA1 areas by characteristics of its population
Once file is ready, save it first, as you cannot ‘Save as’ after you have prepared a map

Double-click layer in Layer Frame > select ‘Style’ tab in Layer Properties window


[image: ]Select ‘Graduated’ at top of window 


[image: ]Column: select the field whose values you wish to map  


Symbol: Click [image: ] & ensure that ‘Simple fill’  fill style ‘Solid’ (and not ‘no brush’)

[image: ]
Colour ramp: select the palette                               
(Use ramps of similar colours: Blues, Greens, Greys, OrRd, Purples, Reds, YlGn, YlGnBu)

[image: ]
Number of classes: select number of categories for your data to be grouped by 
[image: ]

Mode: select method for grouping data: Equal interval, Quantile or
 ‘Natural breaks’ (where zeros account for more than a fifth of the values - otherwise 2-3 quintiles may be zeros), then click ‘Classify’ [footnoteRef:1] [1:  For guidance in selecting ranges, use the “Percentile Calculator”. If a high proportion of values in a field are zeros, you may have to use the deciles as a guide to create a single lower range to encompass the zero values, with positive values for the other ranges.
] 


[image: ]The symbols (colours) and value ranges will appear in lower window (click ‘Classify, if necessary)

Double click on values if you wish to alter the ranges – which will alter adjacent ranges as the system seeks to include all possible values within the range of the field


Click on ‘Precision’ [image: ]next to ‘Legend Format’ to adjust no of decimal places in legend



[image: ]Adjust Layer transparency in lower part of window 
[image: ]Apply > OK


Now the colours for each value range will be shown with that layer in the Layers Panel

To change or replace the map, activate and open the layer and repeat the process described above.


Removing a Map
Select ‘Style’ tab in Layer Properties window > ‘[image: ] and choose shape & colour


[image: ]PRINT COMPOSER

New composer: Project > New Print Composer


[image: ]






Existing composer: Project > Composer Manager > select composer required from dialogue box > click ‘Show’


[image: ]







Either way, the Composer window opens:






Resizing Print Composer
Click on magnifier icons [image: ] to change size of composition area on the screen. 
Click on [image: ] for a good fit for your map or on [image: ] at lower edge of screen for a precise adjustment

Adding a Map
To add the map: click on icon [image: ] then draw a rectangle in the Composer and an image of the current map appears
[image: ]
Moving the Map/other Features   
To move the map frame or any other map feature, click on . 
Then click inside the map, hold the left mouse key down and move it around. 
To expand the map, click on edge of the map, hold left key down and drag.

Moving Contents of Map
Click on [image: ] to move the contents of the map without moving or altering its frame

Adjusting Size of Map
Click ‘Set canvas to map extent’ in Map ‘Item Properties’ window, to adjust map to its size in Canvas
[image: ]
Adjusting Content of the Map          – updates Composer to match changes in Map Canvas – not size. 
[image: ]Map window characteristics
Get picture right on Map Canvas first
Composition: this window applies to the overall composition window, and specifies the page size, orientation, number of pages and export resolution (lower image)

For ‘portrait’ layout set the ‘Composition’ window to portrait, create map as usual. The map in Map Canvas will be presented in its full lateral extent in Composer, though its vertical extent in the Composer will be greater than on the Map Canvas 


Frames
Selection: Click ‘Select/Move’ [image: ]button and select frame of any object in the Composition window
Deletion: Click same button, select frame > press ‘Delete
[image: ]Item Properties Windows: When you select a frame around an object in the Composer, a panel with the tab ‘Item properties’ appears to the right of the screen presenting options for adjusting its appearance and characteristics.
Items Window: Shows the objects in the Composer. 
Unchecking item at left hides it
[image: ]




Main Map
For the map itself, ‘Item properties’ window is at left.


















[image: ] ‘Set map to canvas extent’ adjusts map to its size and position in the Map Canvas
By contrast, refresh        adjusts map to reflect its contents in the Map Canvas – but not size

Overviews: See information about inset maps


[image: ]
Place a frame around the selected map/object
[image: ]Adding other items                                   Map

                                                                  Picture

                                                                  Text

Click on buttons                                        Legend

on the left-hand side of the screen            Scalebar










Text
Click on [image: ] icon, then use left-hand mouse button to draw a text box on the composer.


[image: ]
When the text box is selected, its ‘Item properties’ frame appears at right.

Type the text into the area under the heading ‘Main Properties’.






Click on ‘Font’ to adjust the font type, size, colour and alignment. 





Adjust horizontal and vertical alignment






Place a frame around the title


Give a background to the title, if required



Scalebar
Click on scalebar icon [image: ] at left, then draw on screen to get a scalebar. 
[image: ]As with selection of box for image, when you select the scalebar, the panel on the left allows you to adjust features such as:















· Choose segments to the left of zero
(usually none) and to the right


· Select number of meters per segment to create a suitable size for the scalebar




· Height (that is, the thickness) of bar





· Font size and colour




Images and North Arrows
[image: ]To add an image, click ‘add image’ button [image: ] at left, then draw a frame on the map for placing the image.
Picture Properties window appears at right, with options for adjusting your image


Click on ‘Search directories’ to locate mapping images, such as a north arrow

Otherwise, click on button next to ‘Image source’ to locate some other image in your directory.











Legend
Click on the legend icon [image: ] at left, then draw a box in the Composer and a legend will appear.

[image: ]When the legend box is selected, a window will appear at right (as usual) with options for adjusting the legend

To make changes, unclick the ‘Auto update’ button

You can:
‘- add or remove layers  [image: ]or map categories that are visible in Map Canvas

‘- move legend items up/down [image: ] 

- change the title (ie: ‘Legend’) adjust font of title, subgroup (ie: name of variable) or item (ie: usually the numbers) 


[image: ]- double-click on any legend item to view a window and change its name





[image: ]
 ‘- add a frame                           & perhaps a background 

Adjustment of precision of legend ranges in Layer Properties in Map Canvas, will be reflected in Composer

If you click [image: ] or check ‘Auto update’ at the top of the legend panel, it will obliterate changes made to the legend and revert to its original format and content.

Adjusting Positions and Placement of Map and other Images in Composer
Two or more images – such as the map, scale bar, north arrow or picture – may be grouped, locked, moved in front of, or behind, each other, or aligned.
[image: ]Grouping: select items while holding Shift key, then click on group or ungroup icons [image: ]
Locking images: select image/s then click [image: ]buttons

Moving items in front or behind: Select item then click [image: ] which gives options

[image: ]Alignment: Shift-select items and click [image: ] which gives options 


Moving items up, down left, right Select item, hold Control and
 tap up and down keys


Adjusting background: for legend, toolbar, title, check ‘Background’ in Item Properties window, and choose a colour, or leave it unchecked for no background
[image: ]Adding an Inset Map
Creating Inset Map
In Map Canvas, zoom into area that you want as your inset
In Composer, click ‘Add map’ icon [image: ]and draw frame for the inset map. The inset map will now appear. With the insert map frame still selected, click ‘Set map to canvas extent’ if it helps







[image: ]Select inset map (or select ‘Map 1’ in the items list window) then check ‘Frame’ and choose a colour/thickness for a frame around the inset map



[image: ]
Adding Overview
‘* Select main map (‘Map 0’ in items list window)
‘* In ‘Items properties’ window > Overviews > click green cross.
‘* Then for ‘Map frame’ select ‘Map 1' - This instructs that overview should correspond with the inset map – which is Map 1’
* In ‘Frame style’ click ‘Change’ to alter colour of the overview
[image: ]


[image: ]
* To remove overview, 
uncheck ‘Map1’ in Items window 






Exporting the Composer Map
Click on buttons at the top of the screen: [image: ] - to export the image within the Composer as ‘Image’ as JPEG (and other image file types), SVG and PDF files, respectively.

Clicking on either of these buttons will first update the map in the Print Composer to reflect any changes in the content of the Map Canvas, then create an image of the resulting Print Composer.
So once you create a map you like, don’t change the Map Canvas!


SETTING PARAMETERS

[image: ]Setting Default Parameters

Projections

Settings > Options > CRS Tab

Check ‘Enable ‘on the fly’ re-projection – it’s usually the default

Select projection types for new projects (above) and for new layers (below)


Set projections at GDA94 / MGA zone 55 as the ‘Default CRS for new projects’ (uppermost, above) and as  ‘CRS for new layers’ (below)

[image: ]To select from the long list of options, click on the [image: ] icon to the right, then type in GDA94 in the filter section of the window,                                              to filter for projections with these letters and numbers.

[image: ]

















[image: ]Rendering







[image: ]Map Tools







Setting Layer Projection
Double click on layer > in Layer Properties window > General tab > Co-ordinate Reference System
Default CRS (EPSG:28355 – GDA94 / MGA zone 55)
[image: ]




[image: ]

Save As for Layer Projections
In window where you give the name and location of the new file, check its CRS is set at the default and check ‘Extent (current layer)



Setting Project Projection
Project > Project Properties > 
[image: ]



[image: ]








                          Select ‘CRS’ tab and choose projection






PROJECTS

Creating Projects  
Project > New  [image: ]  Then open layers etc. to commence the new project 

[image: ]Saving Projects

Project > Save


Project > Save As > 

[image: ]
Select location and name for the project
(leave no spaces in project name)

Opening Projects
To open a project: Project > Open > then select the project from the file where it is stored
Only QGIS Project files will appear in your search.


INSTALLING PLUGINS & REMOVING QGIS
Plugins > Manage and Install Plugins [image: ]
[image: ]
Select from the list of plugins > Install plugin



Useful plugins may include:
· Open layers
· Freehand drawing



Removing QGIS – e.g. from Home
Left-click [image: ] icon > type QGIS in box 

[image: ]Right-click on QGIS when it appears in the programs list
[image: ][image: ]

View ‘Target:’ which gives its location










Practise Exercises



Select	By button / by form
	By expression / filter by expression
	By boundary / clip by boundary

Create layers	Polygons	Adjust format 
		Move
		Create and remove nodes

	Dots	Adjust format
		Map by category – making some disappear
		Label and format labels
		Create labels field & label by rule using labels field
		Create a buffer zone

Label by Rule		Using an expression eg: Geocode In (‘Cardinia’, ‘Casey’ etc)

Connecting addresses to map	Look up addresses in PropertyNo layer, use expression to locate them, pin dots to them

Attribute Table (SA1 areas)	Review add/delete feature, delete/add field, calculate field
		Calculate a decimal field using ‘to-real’ function
		Calculate a field using Case….End
Still on SA1 areas	Add a field using the CSV file 
		Map areas by a field

Map Composer	Create a map of the SA1 or SA2 areas map, above

31 | Page
image3.png
Panels
 Toobox Crrl+Alt+T
‘Advanced Digtang Panel
*® Bromser Panel
Browser Panel (2)
GPS Informaton Panel
! Layer Order Panl
* Layers panel

Log Messages Panel
Overview Panel
‘Spatial Bookmarks Panel
Statistcs Panel
“The Scale Panel
UndojRedo Panel
User Input Panel

Toolbars.

‘Advanced Digitzng Toobar

) Atrbutes Toobar
Database Toobar

) Digitzing Toobar

) Fi Toobar

% Help Toolbar




image93.png




image94.png




image95.png




image96.png




image97.png




image98.png
# 7 Schools = Festurestotal: 4, fitered: 34, selectedt 1

282 R0 $EERYERP 00 BBE S

1] Crnder Prnay Sl Scod e a
0] KerborounPrmry sl e [prmary ool a
7] Dendenong rney Sl Pt [F a
5] e [ steet q
) Dandencng St vy bl Shub  [oanrng q]
) Decenang st rmary Schos- potade  [315 q
) e Sms ey s vevor e [mr7 ol
[ Harsed rmary Schod Procpal [Dawd Coraer @
[ reshetdpmany Sl one ot (3727 Ol
] Ly Prinary School - = 4l

1) o Pk prnary Shoc





image99.png




image100.png




image101.png




image102.png
¥ CGD_Properties : Features total: 66896, fitered: 66896, selected: 0

2Rt b ENAFEeP 00 BRE S

o = o |

abe PROPERTY N

| (s
PROPERTY N | | ) case sensitve | Exclce i,
sms | 0 Casesenitve[Excide e
PROPERTY.T | | [Exchde fekd,

soeet [

@] Ocase sestve

oty [ | Ocoesersive [ Exeesed
posade [ |Ocaesensioe [ equin(=)
house_nos 14 @] Ocasesensive & Noteawto
o | ] il o
owers [ | O case serstve [ex

e | | Ocaemste B ey
Property A [ | O case sensive (8¢

Serve pd [ | O case sensive [Exchce e,





image4.png




image103.png
Select features |v| | Filter features |+




image104.png




image105.png
T show Selected Features




image106.png




image107.png
‘ 'CGD_Properties :: Features totak: 66896, filtered: 66896, selected: 2 - o X
/2B =t sENaFEeP o0 BRRE S

£, Bxpression o

RECL] ~1| PRoPeRTIN | ] O Case sensitve [Exclude field.
B G2 e — T
[ 2670 PROPERTY.T [ | [Excoe e,
0 zme L = E— L
[ 257365 Locaity [ | [0 Case sensitive | Exdude fied,
g z:0 Postcode. [ Case sensitve | Excude field,
0 wesn houseros [17 @] [ Casesersitve [Eqiaiio (=)
=] [ ] [Excude feld





image108.png
Select features v




image109.png




image110.png




image111.png




image112.png
7 Select by expression - CGD_Properties
Eresson | runctoncatar |
HUWoEMmMo)

["Street” Like'Churcnills’ and "house_nos'





image5.png
JoC)




image113.png




image114.png




image115.png
'/ Local Governments Victoria : Features total: 79, filtered: 7, selected: 7

/BRIEG @BV Ed PO E





image116.png




image117.png




image118.png




image119.png




image120.png




image121.png
/ Field calculator ? X

Only update 0 selected features
[ createanewfield [ Update existing field
[ create virtual field
Output field name
Output field type | Whole number (integer) v Z
Outputfieldlength (10 [¢] Precson 0 ¢
Expression _ Function Editor
=1 [+ == ][] [ ] fw]  [search group Field ~
to_int{ "Postcode” ) row_number | | Double ciick to add fieid name to
> Aggregates expression string
> Color Right-Click on field name to open
> Conditionals ‘context menu sample value loading
v Conversions options.
to_date
to_datetime Notes
to_int .
v oading field values from WFS layers ¥
to_real Values [search
to_string
to_time “Athol Road Primary School ~
> Date and Time ‘Carwatha College’
v Fields and Values. ‘Chandier Primary School
‘School_Nam ‘Dandenong North Primary School
NULL ‘Dandenong Primary School
Type ‘Dandenong South Primary School'
Private ‘Dandenong West Primary School'
Address ‘Green Siopes Primary School”
Suburb “Hailebury Newlands' v
Postcode < 2
G > Melways Re
Prindpal v | Load values [ _allunique | | 10 samples

Output preview: 3173





image122.png




image6.png
Scle 1:95,288




image123.png
Output fied type [ Decimal number
Outputfieldlength 10 [+





image124.png
GAZETTED L
VICNAMES 1
PFICREATE
R
UFLCREATE
UFLOLD




image125.png




image126.png
/ Schools 2016 - Feature Att.

School Name | L

Trpe s
| private L h
|| addess L
| subub L
| Postode nuL

Melways Ref /it

Phone_Number /L.

ndex L





image127.png




image128.png




image129.png
/ Stop editing

X

@ Do you want to save the changes to layer T_Schools?

Save

Discard

| cancel





image130.png
File name: bt

Save as type: | Text Documents (")




image131.png
File name: | Mapping.csvi|

Save as type: | Text Documents (%)




image132.png
"/, Create a Layer from a Delimited Text

File format

‘Geometry defintion () Point coordinates

CSV (comm separated values)

Recordoptons Number of header ines to discard 0

Field options. [ i fields [ Discard empty fields | Decimal separator is comma.

No geametry (attribute only table)

Layer settings Use spatial index (] watch file

SALTDIGITCODE 2016 Popuation _Limted_Fuercy _ One_par Fomis F__ Sepaate Houses D FltsD_Caravans D Vot =
2 oo s ae 0w om e [F
2 e e sas 756 o o e
5 203 05w n w62 o7 om s
s 204 ) 091 23 o o s
s 20 o ms 1w o750 o o s
o 206 s7 wes 208 s0.00 om0 s -
<l v





image7.png
D P




image133.png
Create Layer ,
Add Layer ,
Enbed Layers and Groups..
‘Add from Layer Definiton Fie.

9, AddDelmited Text Layer...




image134.png
Layers Panel 8 x

g e V&AL





image135.png




image136.png




image137.png
Add vector join

Joinlayer
Join fied

Terget field

Cache jon layer n virtual memory
Create atirbute index onjoin fiel

L Croos i ks e st

5 cov_sA1.pato_vicore 2036

[C] EARLY_LEAV_ 2
[] A0_14 YEAR
[] A15.24 YEA
[] A25 64 VEA
A65_VEARS
[] BORN_AUSTR
[] OVERSEAS B





image138.png




image139.png




image140.png
Create a new field

[7] Create virtual field
Output feld name.
Output fied type.

Stk B i B





image141.png




image142.png
EHEHEEM OB
to_rea(

Search

‘row_number

i

to_datetme
to_int
to_interval




image8.png




image143.png
‘to_real{ "CSV_SA1_Data_Victoria_2016_POPULATION"

<vvvvy

Aggregates.
Conditonals
Date and Time

Fields and Vaues
SALMAINCO




image144.png
New Field

217

b4

365





image145.png
Legend
0.00-151440  0.00000- 1514.40000
1514.40 -3028.80  1514,40000 - 3028.80000
302880 4543.20 3028.80000 - 4543.20000
4543.20 605760 4543,20000 - 605760000
605760 -7572.00 605760000 - 757200000





image146.png
Join layer Join field  Targetfild Memory cache  Prefix loined field
SAL Varisbles CSV fild 1 SAL7DIGIT v 1




image147.png




image148.png




image149.png
Create Layer
AddLayer

@, acdpostars Layers.

/i ddspatiite Layer..
M AcdMSSQL SpatalLayer..
@, Add Orade Spatial Layer...
@ Add WMSMUMTS Laver...
@ addvicsayer

Ctlishiftsy
ColishifR
Ctl4shiftsD
colsshifta

Colishift
Colishifts0
Colsshiftaw





image150.png
 Create a Layer from a Delimited Text File

File Name C:/z Discard folder 4/Coded Venues.csv

Layer name | Coded Venues.

File format (CSV (comm separated values)

Recordoptons  Number of header ines to discard 0 =

Field options. [ i fields [ Discard empty fields | Decimal separator is comma.
Geometry definition © Point coordinates. Wel known text (WKT)

No geometry (attrbute only table)

<Xfield [long v feld [lat 52 coordinates
Loyersettngs (7] Use spatel ncex 7] Use st ndex ] watch e
postode lat long  dstlat dstlong dstance district region_elect ‘expendiure_170701_1712 ~
15 7S 1448725 5763 M4S777 0.5S476327 Brunwck  NorthemMewopoitan 119377562
2 3173 -38.009671 145.141593 -38.0167 145.1667 2.334288259 Keysborough South-Eastern Metropolitan 1328188.89
3 WM an7rETes 1449%421 77667 145 1400508957 Northote  Northem Metopoltan  3051299.52
4 3175 -37.986015 145.213714 -38.0115 145.2156 2.838617345 Dandenong South-Eastern Metropolitan 1494230.54
5 30 anze0ls 120897 NA NA NA Lowsn  Westem vitora 115067758
% i v

o ) [Ccoma J [ ]





image151.png
{ Layer Properties - Schools 2016 | Style L2 o





image152.png
Equal Inerval

Natural Breaks (enks)
Standard Deviation
retty Breske




image9.png
Feature

' CaD_properties
v PROPERTY_N

> (Actons)
PROPERTY_N

PROPERTY T
Street
Locaity

56145

456145
c
310.5000000000
Pacific Drive
KEYSBOROUGH





image153.png
Keysborough
Noble Park
Noble Park North

North Dandenong

‘Springvale South




image154.png




image155.png




image156.png




image157.png
aiport  arrow  captal  crde  cty  diamond ellipse




image158.png




image159.png
¥ Layer rendering
Layer transparency.




image160.png
Single Symbol

Categorized
Graduated





image161.png




image162.png
1.2 New_Isiam




image10.png




image163.png




image164.png
colorramp | WM




image165.png




image166.png
EqualInterval

NaturalBreaks (Jenks)
Standard Deviation
| Pretty Breaks




image167.png




image168.png
[recson [2]





image169.png
Layers Panel
geve-BH0

] tocal Governments Victoria
" Table 2

£ o sk

[ ossconn - 33.00006

] 550000 - se1.0000

[ —

532,00000 - 7572.00000





image170.png
Layer transparency




image171.png




image172.png




image11.png




image173.png




image174.png
Lo gy TR 8 S

Composer Edit View Layout Aflas Settngs

I\QQQHI\E&&&"@ RerppR ¥LEaLE.
O R P = O O = e e e





image175.png
nesep




image176.png
110.0%




image177.png




image178.png




image179.png




image180.png




image181.png
Composition |

Composition
S
e ees) €
width  [297.00 £=4
Height 210,00 L=
-

£=4

etton

¥ Resize page to content

‘Top margin (mm) 0.00 =
Left 0.00 < Right 0.00
Bottom 0.00 =
e

Pocebadrend

i
i

Export resolution 300dp




image182.png
00




image12.png
Layers Panel

LI UG- - el





image183.png
£
o3
ssblis
@ 0OOo00a
£l o oo





image184.png
Scale 180000

Maprotaton  0.009

Draw map canvas tems.

[ Lock layers for mapitem

Lodklayer styls for map item





image185.png




image186.png
Frame
one oo | D -
o




image187.png
© 4 O [




image188.png




image189.png
v _Main properties

[ Render as HTML

v Appearance
e
C Font...

Fontcoor (I -)

Horizontal margin 1,00 mm

Vertcalmargn 1,00 mm





image190.png
of




image191.png
Scalebar

¥ Main properties

Mep (Map0 -

stve (Sngesox B
v units

scebarunts fwews ]

Label unit multiplier 1000000000 —

Label forunits  km

af
Fit seqment width min 50 mm
max 150 mm
» Display

|~ Fonts and colors





image192.png
e
Fo—
(zn s
==
[hede

Image search paths.

[CHPROGRA~1/QGIS2~1. 14/appslags vfevs

=

v SVG Parameters

il color

oute cir | D -




image13.png




image193.png




image194.png




image195.png
Legend

Virap texton
[¥] Resize to fit contents.
v Legenditems
[7] Auto update

Update al

0.4-03

W oos

15-25

[ e

wia

7] Orly show items inside current atis feature:

[w] Fonts.

[ et

Subgroup font...

(
[ o ot
(i

Ttem font...





image196.png




image197.png




image198.png
! Legend item pro... (L8 |MES

Item text

o]
(= =





image199.png
v [ frame

rame coor | (D ~

Thdness  [0.30mm




image200.png




image201.png
Bring to Front
Send to Back

51
jTﬂ@S





image202.png
© L




image14.png
Crlsshifts





image203.png




image204.png




image205.png
Aign Right
AignTop

Aiign Center Vertical
Align Bottom




image206.png




image207.png




image208.png
I




image209.png
]
rame coior |

Thikness 0,30 mm

Frame.





image210.png
w [ Draw "Overview 1" overview

o one
roee | Bows. |
Sendingmode




image211.png




image212.png




image15.png
339938,5744768 @ scle[ 1575804 v|@ Maonifir[100% [+] Rotaton [0.0 (2]





image213.png
By By &




image214.png
Dot enable 'on the iy reprojection
‘Automaticaly enable ‘on the iy reprojecton flayers have different CRS
iy reprojection by defauit
‘Always start new projects with folowing CRS
lected CRS (EPSG:28355, GDA4 | MGA zone 55)

v CRS for new layers.
Vhen 3 new layer is reated, or when a layer i loaded that has no CRS

Prompt for CRS

Use project GRS
@ Use adefault CRS | Selected CRS (EPSG:28355, GDA94//MGA zone 55)

¥ Default datum transformations
‘Ask for datum transformation when no defautis defined

&=





image215.png
/i Coordinate Reference System Selector





image216.png




image217.png
/ Coordinate Reference System Selector

Fiter GDASY @
Recently used coordinate reference systems.

Coordinate Reference System Authority ID
|GDAS4 /MGA zone 55 EPSGi2835S.

< 0 0
Coordinate reference systems of the world [ Hide deprecated CRSs.

Coordinate Reference System
GDAS4 / MGA zone 51
GDAS4 / MGA zone 52
GDAS4 /MGA zone 53
GDAS4 /MGA zone 54
GDAS4/ MGA zone 55
GDAS4 / MGA zone 56
GDAS4 /MGA zone 57
GDAS4/MGA zone 58
GDAS4/ MGA zone 53

< 0 o

‘

Selected CRS:  GDAS4 / MGA zone 55




image218.png
£ Options | Rendering

S
3y defauit new layers added to the map shouid be displayed
e ey e i ey s | ] e ores e

Map update interval 250ms [+





image219.png
‘¥ Measure tool

neovics ()

Degima places 3 =

Keepbase unit )

el dm [k =
oo — 5
Preferred angle units [pegrees =)

v Panning and zoming
Mouse wheel action





image220.png
 Layer Properties - Queryl | General g

R e &
Layername  Queryl displayed as Query1
Layer source  U:/Community Services/Mapping/95 Dandenong Club App/Mapping/Query1.TAB





image221.png
Fomat (EsRLSrRpeR

Saveas NewFie

<GRS_[Selected GRS (EPSG:28355, GDAY% MGA zone 551>
Gt

Save orly selected featres
] skip attribute creation

Add saved fl tomap

Symbalogy export (o symbobogy -
v Geometry

oty

Force mult-type:

Inciude z-dmension





image222.png
8
B sovess..
=




image16.png
143,39 146,





image223.png
¥ Project Properties | CRS

Enable ‘on the fly’ CRS transformation (OTF)

Fiter

Recently used coordinate reference systems.

Coordinate Reference System Authority ID
= Generated CRS (+proj=utm +20ne=55 +south +elps=aust_SA +ongs84=-133, . USER:100000
|GDAS4 / MGA zone 55 EPSGi28355.

<

Coordinate reference systems of the world

Coordinate Reference System

GDAS4/MGA zone 46
GDAS4 /MGA zone 47
GDAS4/MGA zone 48
GDAS4 /MGA zone 48
GDAS4/MGA zone 50
GDAS4 /MGA zone 51
GDAS4 /MGA zone 52
GDAS4 /MGA zone 53
GDAS4/MGA zone 54
GDAS4/MGA zone 55





image224.png




image225.png
SIS

[ ew
1 gpen

New From Template





image226.png
File name:

Save as type: [ QGIS files (*.qgs *.QGS)




image227.png




image228.png
- AutoFields

e sutosaver
e AutaTrace

- Adimthand Distance Calctor
- Adimth and Dstance Fugin

v Backup layer

- Batch GPS Inporter

+ Batch ihader

+ecine

- beepen

6T Import

BN Exporter

Arrows

Draw polygon arrows based on polylines

et 22 rating vote(s), 33628 downloads

More info: homepage tracker code repository.
Author: Gregoire Piffault

Available version: 0.2.2 (in QGIS Official Plugin
Repository)

[upgrade al |





image229.png




image230.png
» AllPrograms.





image231.png
@ QIS Browser 2147 Properties.

Seouty | Dos | Frevous emons
Genedl | Swnox | Compatbity

@ ossromrir

Tergettype:  Applcation

Tergetlocaton: bin
Terget: "C:\Progrkm Files\QGIS 2. w-.w
Satin CAPROGRA™1\QGISZ1. 146

Shotcutkey:  None

Run

Commert:  QGIS Browser 2.14.7

(000 e Locaton ] ([ Crange fon. ] (_ Advanced.

o] e

Aoy





image232.png
Programs (5)
@ 0Gis Browser 2147

@ QGlsBro 557,04
7 ags pered Q08 bowe 147 |

QIS Desktop 2.14.7 with GRASS 7.0.
# Qt Designer with QGIS 2147 custom

Files (61)
) Notes on QGIS March 15
) Notes on QGIS March 14
) Notes on QGIS March 13
) Notes on QGIS March 11
3] agis
4] qgis-auth

D See moreresults




image17.png
5 selectFeatre(s)
6 Selct Features by Polygon




image18.png




image19.png




image20.png
"/ Local Governments Victoria

/B

Geos_CODE.

stures total: 79, filtered: 79, selected: 6

NEEREEELYEEIL

Ararat

Balarat





image21.png




image22.png




image23.png




image24.png
Values Search

e E
e
o E





image25.png
[ 50 3] 150 72 [ | 9 B[ )

"GeoS_CODE" = 'Alpine’

General
Geometry.
Math
Operators.
%
I
n
+
<
<«
<
>
.
AN
LiE
N
5

operator =
‘Compares two valies and evaluates to 1 i they are equal
syntax

»





image26.png
[, Addto selection
L Remove from selection
) Select within selection




image27.png




image28.png
.

Set provider fiter on Local Governments Victoria

Filds Values
Geos_cooe eater Dancenong
Greatr Gecony
Tovang
[ Sample ] ( A )
] e fitred s
v operators
=) e ) e ) ow ] o )
=== J w0 ) [ ][ ]
Provider specificfiter expression
oo tcoorarmrive
o [t ) [Cger ] [Ccns ] [ )





image29.png




image30.png
é

Random Selection...
Random Selection Within Subsets.

Random Points...
Regular Points...
Vector Grid.
Select by Location.




image31.png
 selectbylocation TG Rl e

| st

[Cymsover B

| ratitasec fsturesi

[Cayesver =
Tndude nput festures that intersectth selcton feaures

Tndude nput festures that touc the selecion feaures.

[T include input eatures that overlap/cross the selection features

[7] Indlude input features completely within the selection features
ot seces s>

(ceatngnew seecton =

[ 0% oK Close.





image32.png
31

cldalsilss <£lsllsz| 21041818 clail R
212\14131124 2151124 | 212041311 21511 21204
2131127 212041311 21311 21204

a 21204131127





image33.png




image34.png




image35.png
gE

Research Tooks »

IHB IBE:?




image36.png
rputvectorlayer
[eds 18

7] Use oy slctd eatures
Ciip layer
Lo Coremmeni Ve

e oty st esnass™

Output shapefie

[¥] Add resuit to canvas.

0%





image37.png
7 cip

Parameters  Log

Inputlayer

SAL victori [EPSG:28355]

Clplayer

Clipped

[Create temporary layer]

Open output file after running algorithm





image38.png




image39.png
Vector |
openstrestiap ,
Research Toos »

[ oo Tods |V (9 imrsecton
Geometry Tools. >

O Symmetcl dfference

anaysis Tools » P Varcble distance buffer
Data Management Tods > Uiion

|ll’aﬂv=




image40.png
/ Difference

Parameters  Log

Inputlayer

Suburbs_vic [EPSG:28355]
Difference ayer

T_Filtered_ Municpalty [EPSG:28355]

] tgnore nvaidinput features [optonal]
Difference

[Name of cipped layer





image41.png




image42.png
Layess Panel

LI UG- - el





image43.png
Create Layer »

#, New Temporary Scratch Layer..




image44.png




image45.png




image46.png
. Add vector layer

Source type
® Fie ) Directory.

Encodng [ System

Source

Database

Dataset





image47.png
SV Desiation_Zones Dota
CSV_sA1__Data_ 2016 cco.
CSVSALDota Vetoria_ 2016
B oot ausronr

o 20te_ausTep
© on_anie avsu
£ Dzn_2016 AUSTtab





image48.png
L] Test layer.dbf
Test layerpi
L] Test layerpj
| Test layershp
] Testlayershx





image49.png
Layer
Create Layer
AddLayer

VG Add vector Layer..





image50.png
Fomat | ESRI Shapefie [

saveas [ | [ mowse |

GRS | Selcted CRS (EPSG:4140, NADBCSRSSE) [-[)

Encodng

] Save only selected features
|| Skp attribute creation
% Add saved file to map




image51.png
Create Layer
AddLayer

EnbedLayers and G
‘Add from Layer Defri

Copy style
Paste style

Open Attribute Table:
/  Toggle Editing
} saveloyerEdts
J cumentdts

o




image52.png
' Selct Features by Polygon
2 Selct Features by Frechand
[ Select Features by Radis.




image53.png
/ Save vector layer as... . A

Saveas

RS Selected CRS (EPSG:4269, NADS3)

%) Save oly selected features
'Skip attbuts creaton




image54.png




image55.png
Selectby layersn the fo

Shapefe e rovgon s
I Ioutles
i =
Ouput hapete
Addresttomap camas
[ J o
[ J o





image56.png
/ Select input files

tonki: <[ o ConactatY s arEs

A 1y Computer || L Lo Governments vt st || 7_0hp Testabn [

| Q_suburbs_Vic.shp. L T_Clip2.shp
R o 11 o pmended victornsho [ Tap3ste |

) suburbs vic Amendedshp | | T_Clpashp [
L] T_Airport_West Fitered.shp [ j T.Clipé.shp. [





image57.png
¥ Merged:: Festurestotak 40, fikered 0, selected: 0

/28BR SENRYZRP SR REE S
[l School_tam e prvate addess surb Postcode:

1 o o o o 0
2 20 ] ] ] ] 0
3 30 ] ] ] ] 0
4 40 ] ] ] ] 0
s 50 o o o ° 0
g 50 ] ] ] ] 0
7 0 Chandes Prmary.. PrivarySchool P S19Codvane A Keysbarough 173
s 0 KeysboroughPri.. PrinarySchool 41:51 Coamoora . Springvale South an
g 0 DandenongPrm... PrivarySchool 174182 Foster 5. Dandencng 75 ¢
» 0 Dendenongort . PrinarySchool 117-125Cclan.. Dandencng

n 0 DandenongSout.. PrivarySchool S2krihamRoad  Dandenang 307




image58.png
7 New Shapefile Layer

Type

@® Point O une O polygon
Fie encoding [system -]
‘Selected CRS (EPSG: 28355, GDA94 / MGA zone 55) ~f&
Hew field

Name | |
Type [Textdata -
N —

Fields list

Name Type Length precson

id Integer 10

< >

| Remove field





image59.png




image60.png




image61.png




image62.png
T_Dots_3 - Feature Attributes

Name |Dandenong High School




image63.png
Create Layer





image64.png
# New Shapefile Layer 7 X

Type

@© ot O tine O Polygon
Fie encoding system
| Selected CRS (EPSG: 28355, GDA94 / MGA zone 55)

New field

Name

Type Textdata

Length 80
Fields list

Name Trpe Length Precsion
d Integer Y}





image65.png




image66.png




image67.png




image68.png
x|




image69.png




image70.png
{8

treetitap »
Analysis Tooks »
Research Tools »

0o otEn





image71.png
[Srmnco -

Dissalve buffer resuts
Output shapefie

rest to canvas.





image72.png




image73.png




image74.png
! Layer Properties - Local Govgmments Victoria| Syle

—
o (-

simoasngmn

W srge
comers dingonsl doited  green




image75.png
T e Properies - Lol Goverrnens Vs v S| TR
overmnen: veorn e SN — <=8

& stie

Symbol layer type |Simple fill -
o [ 6 o T &
Fisyie  [[llsoid
= Soder stje. [——soldiine e
e sonstie  [gyBevel i
X &

Sdervidth 0.400000 B




image76.png
7 Selectfill color

2

os N
o I o ]
o T [ 3
0 I

o PSS [n

Opadty S [~
HTM.notaton





image77.png
Ly Properies - Schock 2010 | | eSS

-

Ssmgesmbol __~

Symbol layer type |Simple marker -
[ S— coos  Fa [EET] & ousne (NN -
sae 2.000000 5 & [pmeter -
Outin st [——saitne SR=1,
4 0 Marker
Outine with 0.400000 5 & [pmeter -
© simple marker
fge  oo0e He
Offetx,Y  0.000000 5] 0.000000 5 & [pmeter -
Anchor pont. HCenter. ~] & [veenter PR=S
QOO O+ XAAXxKXTT |
> b
(&) (=] (@) (@ (4] [7] Bowmees (i
¥ Layer rendering
Layer transparency 0] o [





image78.png
. Layer Properties - Queryl | Labels N

9 Show labels for this layer =

Label with [ 1235A1_7DIGITCODE _2011]

v Text/Buffer sample

Lorem Ipsum

Tt s
b

O Fomattng || oy ot
e puffer
@ sdpond || sy Nornal
' Shacon
% Plocement

7 Rendern
P ° Size 6.2500

s




image79.png
Size

05




image80.png
Offset from centroid

© Horzontal (sow)
© Free (sow)




image81.png




image82.png
/ Add field L2





image2.png




image83.png




image84.png




image85.png
Rule properties

Ce b ) ‘





image86.png




image87.png
 Expression string b





image88.png




image89.png
Descrption
Fiter Label =1
[ Scale range.

Miimum
(exdusive) 7=

1:100,000

Label with abe GeoS_CODE|

Masimum (@)

(ncusive) &

11,000

v Text/Buffer sample

Lorem psum

Lorem Ipsum @

e Text Textstie

%8 Formattng Font 1 ShellDig 2. 5

abe guffer

@ sadoond | Stre [Normal .

D shadon =

2 Hocement Ueble

 Rendering ES 5.2500 :

= -

Color -




image90.png
Add...
Rename Current...

V]| @efait)





image91.png
/' Primary_Schools_CGD :: Features total: 34, filtered: 34, selected: 4

/2BR I 8aENRTYESR S
School_Nam Type Private ‘Addres

1

|2 KeysboroughPri... PrimarySchool 41-51 Coome

6 Dandenong West... Primary School ~ F 32Birdwood




image92.png




